Minimum Requirements

Just like any piece of software, our Extras have minimum requirements to run on your server. We increase these requirements regularly so we can take advantage of new features and possibilities to provide you with better tools.

The following requirements are for all of our extras, and were last updated on 2019-01-29.

Some extras may have other or higher requirements. Keep an eye out for those requirements in the documentation.

MODX Requirements

We use a rolling support schedule for MODX releases. When a new minor version (e.g. 2.6.0) is released, we continue to support the previous version for one year. We also aim to resolve, or at the very least acknowledge, any conflicts with new versions within two weeks of their stable release.

Following this schedule, we ended support for MODX 2.2 on on July 16th, 2015 (see announcement), for 2.3 on August 19th, 2016 (see announcement), and for 2.4 on April 22nd, 2017 (see announcement). Support for MODX 2.5 will expire on March 12th, 2019 (see announcement). Support for MODX 2.6 will expire on November 27th, 2019 (see announcement).

MODX 3

MODX 3 is currently in progress. When a release candidate comes out, we'll evaluate the effort involved in making our extras work. As the specific breaking changes in MODX 3 are still somewhat uncertain, we can't make any promises yet on how long it will take to resolve any potential issues, but will post on our blog as soon as we have confirmed our extras work as expected.

We welcome bug reports related to MODX 3 through the usual channels, but will prioritise keeping our extras working in MODX 2.x if there are breaking changes to address.

PHP Requirements

As of January 2019, we're implementing a rolling support schedule for PHP versions. To give you enough time to get your servers updated, that rollout is planned as follows:

  • Currently, we support PHP 5.5+
  • On July 1st, 2019, we're increasing the minimum to PHP 7.1 (6 months after the official end-of-life date of 5.5/7.0)
  • On March 1st, 2020, we're increasing the minimum to PHP 7.2 (3 months after the official end-of-life date of 7.1)
  • On November 30th, 2020, we're increasing the minimum to PHP 7.3 (on the official end-of-life date of 7.2)

After November 2020, we'll follow the official PHP support timelines.

See the announcement about the rolling support schedule.

Note that for new extras or major updates released prior to July 1st, 2019, we may already require a higher PHP version.

navigateup

Disclaimer: Viewing non-Euro pricing

You are currently viewing prices in a non-Euro currency. Please be advised that these prices are estimates, based on data by Open Exchange Rates.

While we offer this currency converter hoping our users find it convenient, all purchases are made in Euro, and the final amount charged can vary depending on payment provider, day, time of day and a number of other factors outside of modmore's control. There are no guarantees on accuracy and modmore nor Open Exchange Rates can not be held liable for errors.

×