Our extras now require PHP 7.1 or higher

As announced a few months ago, we've increased the minimum PHP version we support to at least PHP 7.1. This allows us to take advantage of more modern coding patterns and third party libraries.

If you're not yet on PHP 7.1, you should start planning that upgrade as soon as possible. PHP 7.1 has been around since December 2016. It offers many benefits over older versions, including improved performance and new powerful language features.

The overview of your licenses will list the PHP version we have on record for each site, and SiteDash users can use the advanced search to lists sites on PHP 5 or 7.0.

The next bump in minimum PHP versions will occur in March 2020, when we'll start requiring PHP 7.2 or up. Learn more about our minimum requirements here.

Mark Hamstra

Mark is the CEA at modmore where he helps people doing more with MODX. He accomplishes this by providing premium extras with great support and documentation, and other initiatives meant to help MODXers around, like MODX.today.