Support ending for MODX 2.4 and PHP 5.3/5.4

As of tomorrow (April 22nd), we will cease supporting MODX 2.4 as per our version support policy. We’re not planning to release any updates that will break in 2.4.x right away, but it is possible you’ll run into 2.4 specific issues in the future. And given the significant security issues resolved in 2.5.2, upgrading isn’t a bad idea anyway!

We’re also going to stop supporting PHP 5.3 and 5.4 in 3 months from now (July 21st, 2017). A minimum of PHP 5.5 will then be required for all our extras. This enables us to use newer language features and prevent oopsies like this.

If you haven’t upgraded to PHP 5.5 (or higher) yet, the security and performance improvements alone are well worth a quick email to your host to get that sorted out.

About the author

Mark Hamstra is the CEA at modmore where he helps people doing more with MODX. He accomplishes this by providing premium extras with great support and documentation, and other initiatives meant to help MODXers around, like MODX.today.